Home Theater Forum and Systems banner

Replaced IC's and resistors in 43UWX10B. Resistor smokes immediately.

7308 Views 32 Replies 2 Participants Last post by  lcaillo
So as a project, I purchased a used 43UWX10B off of craigslist. I purchased it knowing that it had convergence issues. I ordered the X480293 kit (Sanyo), and replaced the IC's and the resistors. It looks like the repair had already been attempted because of the of the resistors in question had new solder. Anyway, I didn't find any bad resistors but I replaced them all anyway. After hooking everything back up, I turned the TV on and right away, resistor RK54(1.5 Ohm) starts smoking. It's completely discolored and its out of tolerance now. Any suggestions? Also, I took a picture of the "innards" before I took it apart and now I discover that the wire to the blue PCB was not hooked up when I brought it home. Only the green and red were. This leads me to believe that the previous owner knew there was a problem with the blue but it might be a red herring. Any suggestions? Also, where can I buy the correct resistor locally?
1 - 20 of 33 Posts
Could be a shorted blue convergence yoke. Was the connector in place when you smoked it?
I'm assuming you're referring to the connector that was not attached when I purchased it. Yes, I reattached it after I replaced the IC's and resistors. Would you recommend I just unplug the cord labeled blue PCB?
NO. That will almost certainly damage resistors and likely a chip. I would look for dc offset on the inputs to the ICs and bad solder connections.
I've checked and rechecked the solder. I think it's good. I'm not sure how to check the DC offset. Could you point me somewhere to read up on it?
Did you check for bad solder on other areas of the board?

You check for dc offset by simply measuring the voltage at the inputs to the ICs. I would remove the chips and see if you have more than about 0.1 vdc at the input lines to the amps, you likely have a severe alignment offset or a problem in the DCU.
Thank you so much for all your advice. I really do appreciate it. People like you provide me with the necessary knowledge to tinker successfully. Do you think I can buy a replacement for the burnt resistor locally?
Also, I found a datasheet for the STK392-110. Although I replaced them with the STK394-160's from the X480293 pack, HOPEFULLY the data sheets are the same. http://www.datasheetcatalog.org/datasheet/sanyo/ds_pdf_e/STK392-110.pdf. So I would like to clarify, you want me to measure the DC offset between +VCC and ground or all of the +In and -In's?

Edit: It appears that the max +VCC is 38 volts which is considerably larger than 100mV.
Measure gnd to input. The pins are the same on the ICs.
Ok Leonard. I'm back with some info. I measured from the inputs (Pins 6, 14, and 15) to ground (Pin 2). Here are my DC offsets.

------Ch.1 ------ Ch.2 ----- Ch.3
Chip 1 0.6V :wits-end: 0.99V :bigsmile: 0.094V :sneeky:
Chip 2 0.15V :dontknow: 0.21V :rolleyesno: 0.21V :rolleyesno:

I don't know much of anything about this but almost all of them are greater than 100mV. Am I screwed? The resistor that roasted last time did not give me any problems and the set was on for a good 30 minutes as I checked the offsets. Is this just because the IC's were not in?
.6v & .99v are too high and would cause overheating and eventual damage likely but not immediate failure. I would make sure that the position controls have an effect on this and center them in their range. If this does not reduce the voltage to nearly zero there is a problem somewhere.

You will not damage the resistors with no ICs installed because there is nothing to deliver current to them.

Verify the +/- supply voltages to the chips as well.
Progress. So I was stuck for far too long because I couldn't get into the DCAM screen because I couldn't get into the Magic Focus menu. The Magic Focus was in "Static Mode". I managed to get to the magic focus from the service menu (blue button) by pressing pip mode then pip ch. It runs for 5-8 seconds and then kicks me "Over Flow !" in red. I've pressed the magic focus button to try to get into the DCAM menu but no luck. What do you suggest I do? Also, how exactly do I get those offset voltages lower? From the DCAM or service menu? Thank you for your advice.
You don't "get into DCAM" using the magic focus button. All it does is get you into magic focus. Magic focus is nothing more than a reset to the last stored parameters. DCAM is where you are when you press the blue button. You manually adjust the convergence there using the remote, store the data, initialize the sensor data, then finish with magic focus to have the set operate normally. The only thing you do with magic focus is finish. If you don't it won't work and you will be in static mode. If you don't have the manual you really need to get it and read it carefully.
I've got my hands on the service manual and will be sitting down for a long day of reading. I'm sorry to keep bugging you. Can you explain exactly what factor(s) control that DC offset? When I have the DCAM screen up, I can choose what grid-point and what color I'm manipulating but I can not adjust them. I'm assuming it is because the convergence chips are not in the board but I've pushed the stick in every direction for every color on multiple points on the board but the IC #1 Ch. #1 DC offset still doesn't move at all.
Static convergence (overall position) is affected by changing the d.c. offset on the yoke, while dynamic convergence (shape of the image) is affected by changing the waveforms driving the yoke. With the chips out there will be no correction, but the signals from the convergence generator still change. IIRC, static convergence on these is adjusted by pressing the freeze button. There is a very specific procedure for adjusting it that starts with an offset so that when you adjust the linearity you end up with less dc on the yokes.

There is a discussion of the way these circuits work in the first 10 posts of the convergence repair thread, BTW.
For the life of me, I can not get into the I2C service menu. The service manual says to hold down the input button on the control panel and then press the power button. I've tried pretty much every combination and permutation of this that I can think of and it still does not bring up the menu. The convergence chips are out when I do this. Is that the problem?
Why do you need to get into the I2C menu?
Why do you need to get into the I2C menu?
I was under the impression that I needed to get into the static menu to adjust the static convergence. You said that I need to get those offset voltages down to a reasonable level before I put the convergence chips back in. I have read through all 150 pages of the manual and that's the only place static convergence is mentioned.
You get to all convergence adjustments by pressing the blue button on the front of the chassis. You then need to refer to the procedure in the manual.
I think I finally have some useful info! You were correct in a previous post when you said the "freeze" button takes you into the static convergence menu. I was able to bring 4 of the six down to .1V like you recommended. Red in the horizontal direction is pinned at about 2V and Blue in the vertical direction is pinned at about 1.75V. What would you suggest as my next course of action?
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.