Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I am trying to run REW 5.01 beta 17 on a Mac running OS 10.6.8. I've looked through many of the threads, but frankly there is so much here that it's a bit overwhelming. I'm getting the following error message when I try to launch:

Exception during startup


Message:
java.lang.NullPointerException
Level:
SEVERE
Stack Trace:
null
roomeqwizard.FA.C(Unknown Source)
roomeqwizard.lB.G(Unknown Source)
roomeqwizard.RoomEQ_Wizard.main(Unknown Source)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
java.lang.reflect.Method.invoke(Method.java:597)
apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)


I did see some tips in the forum related to Java, but the suggestions didn't line up exactly with the options I saw when downloading Java updates. I did update to Java for Mac v10.6 update 17, and doing so gave me a choice of using the 32 or 64 bit versions of Java SE 6 in Java preferences. Neither one works.

Thanks in advance for any suggestions!
 

·
Premium Member
Joined
·
6,711 Posts
Is this the first time trying to run REW on that machine or has it launched successfully previously but now won't launch? If it has run before it might be a problem with something in the preferences, on OS X they are in the user's home directory at Library\Preferences in com.apple.java.util.prefs.plist in a node called roomeqwizard, which can be deleted to make a fresh start. If it has never run successfully then that suggests a problem with the Java environment somehow, but not sure what that might be, sorry.
 

·
Registered
Joined
·
1 Posts
On your Mac, which folder/directory is the RoomEQWizardV5.01beta17.app located in?

I found that REW will not launch if the app is not stored in the root of the Applications folder/directory.

I like to create subdirectories in the Applications directory, like one for Audio/Video apps. I stored the REW app there. When I first tried to launch the app, I got a message stating that I needed to download Java. After downloading Java and restarting my iMac, REW would not launch. Moving the app back to the root of the Applications directory solved the problem.
 
1 - 3 of 3 Posts
Top