Home Theater Forum and Systems banner

REW V5.0 signal generator error

4236 Views 11 Replies 3 Participants Last post by  tikko4
Hello--I downloaded REW V5.0 to my notebook a while back. The signal generator works normally when I use the integrated soundcard or connect an external USB card. Today I loaded REW V 5.0 to my desktop which uses a PCI M-Audio 24/96 stereo soundcard. When I tried using the signal generator the tone plays for a second then stops. A small box pops up which says "timed out waiting for space to write the fade out block to the soundcard" I also tried sweeps and different frequencies with no help. After the error box displays the signal generator will not play anything unless I close REW then reopen it. The generator will then play for one second again and the same error displays. Anyone have an idea what I can do to correct this? THANK YOU!
1 - 12 of 12 Posts
Are you using ASIO drivers? If so, try increasing the ASIO buffer size, the driver may provide an explicit buffer size setting or a latency setting, higher latency = larger buffer.
I tried increasing the ASIO from 256 to 1024 with the same results. I also moved the sampling rate from 48K to 44.1K with same result. I returned soundcard to original settings. The card has been working flawlessly since I installed it a year ago and will play any audio except the REW signal generator (it plays the signal generator for about 1 second then the audio stops and the error message displays in a small box. I know this sounds bizarre but that is why I am asking for help--Thank You!!
Could try accessing it via a different driver, e.g. ASIO4All or through the standard Java drivers.
I re-enabled my motherboards integrated soundcard and tried the signal generator with it. Strangely, it played cleanly for about 1 second then a heavy garble (distortion) overlaid the frequency. I was then not able to stop the generator from playing the distorted tone unless I closed REW. This is more bizarre than the problem using the M-Audio soundcard.Updating the driver on the M-Audio soundcard was no help. Deleting and redownloading REW V5.0 made no difference. Since the remainder of REW looks normal I am thinking a bug got into the REW software download since I loaded it on my laptop a few months ago, but this is not likely. Perhaps copying the laptop's REW to a disc and then loading it onto my destop would work?? Your thoughts/further suggestions are appreciated-Thank You.
Could try updating Java on the PC if it doesn't have the latest version, not sure what else to suggest.
Hello John-thank you for trying to help me. Today I loaded REW V5.0 onto another desktop computer running Windows XP (my computers run only XP) and the signal generator played normally. So through elimination I know that the problem is confined to the one computer which I originally posted about. Whatever is causing it is common to 2 different soundcards which otherwise play all audio normally through it. Something on that computer does not like the REW signal generator. My Java/Adobe and all other Windows programs are up to date. Since you are the only one who has responded to me I gather that no one else here has any knowledge of this situation. I accept that I cannot use the REW signal generator on one of my computers & appreciate your effort to resolve this for me--Manny
Hello again--after my previous post I tried one more time to resolve my issue. I verified my current correct installation of Java and used Revo Uninstaller to remove an old download of Java still on my computer. Then I enabled the motherboards Realtek Audio soundcard and to my surprise the REW signal generator played normally through it without any distortion. When I enabled the PCI M-Audio card the generator would not make a sound and I got that same error message mentioned in my first post. After closing & reopening REW I opened the "Levels" meter and then opened the signal generator and it played normally! I found that I had to open the "levels" meter FIRST before opening the generator--if I just opened the generator & tried playing it I would get no sound & the error message. I just wanted you to know--in case someone else in the future reports something like this! Weird but true.
See less See more
Well done for finding that! Just to check, are you still using the ASIO driver setting in REW?
I attempted to update my M-Audio 24/96 soundcard from M-Audio's website-and wound up deleting the original driver. The new driver changed the soundcard's control panel tabs/info/settings. The card's hardware settings page now displays a DMA buffer-latency set at 1024 samples from an available 64-2048 samples. I don't know what DMA or ASIO really is or how they are related. Nor do I understand how opening the "levels" meter first and then the generator allows the generator to play normally. I am just glad that I found out how to get it to work with the M-Audio Delta 24/96 stereo soundcard.
I'm having the same issue. Win10×64 PC Marian Clara E 512×512 Dante PCIe I had this issue with the PCIeR for this and ended up having to calibrate the system via the Dolby Atmos Renderer, Steinberg Nuendo, and Apple "MIDI" (audio) settings for the reference player individually. It's been too much of a hassle and now I need this information to program the SPQ in DADMan (MTRX Studio used as a monitor controller w/ M.O.M.) How exactly was this resolved?? The meters are visible in the preferences window. I don't have any control of that, so I assume those aren't the meters in question here.
I'm also getting "Unable to start ASIO capture". I think I see the "levels" mentioned above on the main screen when I exited preferences, but it also says "Unable to start ASIO capture" when I click it.
1 - 12 of 12 Posts