Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Anyone experienced a successful repair of RS SPL 33-2050 (It's a TRUE Realistic RS model)?

Here's the tests I have done:

- Battery check functions as normal.
- Slow/Fast response function works as indicated by the battery test.
- Disassembled meter and cleaned all solder points (they weren't too bad)
- Display tests out at about 2kOhms per the schematic
- Mic seems to work; It gets about 5.5v and I connected it directly (solder pins) to external source and get sound.
- Tested as many components as I could being soldered in place. (resistors, 4 diodes, single pot etc..)
- Paralleled CAPS with like values and nothing!

All the components of this meter are extremely basic. I'd like to get this thing back to life.

My guess is that the BA301 opamp has gone bad.

Anyone have any thoughts or experiences they like to share. Thanks in advance!
 

·
Banned
Joined
·
516 Posts
Not considering the problem has not been identified, the value of one's time, and that you can buy one for ~$25 on Ebay...or for ~$10 if you want the digital version...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It's ALIVE!!!!

I ended up ordering a BA301 from ebay. It had the same manufacturing numbers as the one in my meter (412 177).

...if you're good at soldering (desoldering), as I am. I recommend this fix.

Levels are the same as my reference.

The time/value argument is always moot.

I hope my experience helps someone.
 
1 - 3 of 3 Posts
Top