Home Theater Forum and Systems banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My Samsung DLP model HLR4667WX/XAA was just completely replaced end of May 2009. It was the color wheel, and when the tech came to diagnose, he just ordered the whole entire unit, which he said was basically the whole insides of the TV, minus the shell. TV was working fine up until about 3 weeks ago, when it started flashing to a blue screen intermittently. When I turn on TV, it will work fine then after a little while, the screen will start flickering, or rolling , then go blue and then a message saying No Signal, which YES there is signal. Another other thing is on the front of the TV is the power button, and it used to light up LAMP in green when you turned it on, and it don't do that anymore. When the blue screen gets stuck, I flip thru the Inputs and when I get back to correct input, screen is ok, for awhile..

Extended warranty thru Best Buy expired in July. Geek squad refuses to guarantee work service or parts beyond 30 days or end of extended warranty. They said they can send service repair out for $150 COD for diagnostic, plus cost of repair...Basically they are saying the unit they replaced was only guaranteed 30 days, all because 4 year warranty has expired! HELP PLEASE!!!!!

Samsung DLP model HLR4667WX/XAA
 

·
Plain ole user
Joined
·
11,121 Posts
I would be willing to bet that they changed the light engine, which is about a third of what is in your set. The problem is likely the digital board, which is discussed in several threads here. I would like more detail on the symptoms before jumping to conclusions, however.
 
1 - 2 of 2 Posts
Top