Home Theater Forum and Systems banner

1 - 11 of 11 Posts
G

·
Discussion Starter · #1 ·
Please help.

I have Samsung HLN437W DLP HDTV. The picture will come on and it will be fine. Then, the picture will freeze black with the last frame outlined in white. Then it may go completely black. Audio is fine.

If I power it off and back on a couple times, picture will work fine than freeze to black again, audio still working.

Has anyone fixed this? What part do I need to replace? I chatted w/ Samsung and they say this is NOT a common issue and this issue is NOT in their support database.

Any feedback would be greatly appreciated. I'll send a six-pack of your favourite beer or bottle of wine to the first person who can tell me what part needs to be replaced.
 

·
Registered
Joined
·
3,251 Posts
Welcome to the forum :wave:

.... I'll send a six-pack of your favourite beer or bottle of wine to the first person who can tell me what part needs to be replaced.
I want a six pack of Sapporo, okay :yes: ... You need to change your TV :rofl2:

Sorry, I'm not making fun of your situation just making a joke, and giving you a Welcome :hide:.

I don't have any experience, but I'm sure Icaillo will respond to your request ... he's the one with experience :yes:
 

·
Plain ole user
Joined
·
11,121 Posts
I am not clear what your symptom actually looks like. Is it a black screen or is it the last frame. Can you post a picture?
 

·
Plain ole user
Joined
·
11,121 Posts
Same on all inputs and resolutions? Menus, OSD?
 

·
Registered
Joined
·
1 Posts
I am having the same problem....I have tried all the inputs, and it still freezes black and white but the sound is still good. does anybody know what the problem is? I was told it might be the dig board,or something else but I cant remember what.... A TV repairman told me it would coast about 1000$ to fix. but the TV is not worth it.
 

·
Plain ole user
Joined
·
11,121 Posts
What, precisely, was the diagnosis by this "repairman?"
 

·
Registered
Joined
·
16 Posts
Was anyone able to resolve this problem? I have a HLR6168WX/XAA and the TV turns on fine but after few minutes of working without any issue, left half of the screen goes dark, while the right side of the screen has a frozen black and white image of the last frame. The background is black while the frozen image is white if that makes a difference. Turning the TV on and off resets it and the TV starts up fine only to go to the above condition in a few minutes again. The sounds keeps going. The issue occurs on all inputs and using both HDMI or RGB cables.
 

·
Plain ole user
Joined
·
11,121 Posts
Start a new thread with the model and primary symptom in the subject. Describe your problem in as much detail as you can, including what it does with different kinds of inputs, whether menus and OSD are affected, and how it behaves over time and with different signals.
 
1 - 11 of 11 Posts
Top