Home Theater Forum and Systems banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I currently own a non-functioning, Samsung HLR5067WAX/XAA, MFD Oct.2005.
Purchased new several years ago, in box, from a retailer.
Installed in home, operated fine until recently.
Issues below in, ordered to best of my ability.
Diagnose/repair help is appreciated.
Issues:
1. Plug unit in, powers up without pushing "Power" button.
2. Screen lights up for 5 to 10 seconds then goes Black.
3. Annoying musical tone accompanies Black screen on/off sequence.
4. Cable or DVD video and audio input function ok, except Black screen on/off and musical tone.
Questions:
a) Any suggestions on where to start looking for a problem?
b) Any links to a service manual PDF?
 

·
Premium Member
Joined
·
3,777 Posts
Welcome to the Forum. Someone will help. Have fun. Dennis
 

·
Plain ole user
Joined
·
11,121 Posts
Most likely a bad lamp. Also check the tactile switches on the control panel. Could be a bad digital board if neither of the first two turn out to be the problem. I would look in the threads for similar sets to yours for links to a service manual, or check the recommended sites in the stickies in the Service and Support area forums, and the vendor listing.
 

·
Premium Member
Joined
·
8,112 Posts
Hello,
Given the age and the price of Replacement Parts, you really might be best served replacing the Samsung.
Welcome to HTS. Really glad to have you with us.
Cheers,
JJ
 
1 - 4 of 4 Posts
Top