Home Theater Forum and Systems banner

1 - 20 of 20 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey,

I have a Samsung DLP rear projection TV. Model Number HLR5067WAX/XAA . When i try to power it on the "LAMP" lights up in green on the front power button. Nothing comes up on the screen and there is a loud whirring sound. No sound or picture ever comes up. Then it will go back to standby. Is this just a bulb problem?

Thanks
FERG
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Well, I have been having the above listed problem for the last month or so. I had made several attempts at powering it up with no success. It has been sitting unplugged for a month now. I plugged it in today to verify what was wrong just prior to posting above. Now it powers on and the screen comes up. I can see the menu but the image is weak looking and flickers. The loud whirring noise is still present. any thoughts? Thanks in advance for you help!
 

·
Plain ole user
Joined
·
11,121 Posts
Loud whirring is possibly a color wheel, the rest sounds like a bad lamp.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Thanks for the quick response.

Bad bulb? Even though it now turns on? Would a bulb still work intermitently if its bad?

Just to help settle my mind before I buy parts. What are the indicators for a bad light engine?

How can I test for a bad color wheel to be sure before I buy one?
 

·
Plain ole user
Joined
·
11,121 Posts
Intermittent lamps happen all the time. If you get a lamp LED lit the first thing to try is the lamp. I have them if you need them.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Intermittent lamps happen all the time. If you get a lamp LED lit the first thing to try is the lamp. I have them if you need them.
How much?
The lamp Number I have is BP96 00826A (P)

I'd prefer the one with the case

NEVERMIND: I found it on the shacks webpage. Cheaper than others!
 

·
Plain ole user
Joined
·
11,121 Posts
Where are you getting it, how much, and what is the warranty?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Through the hometheatreshack.com for $99 and it doesn't say anything about warranty.
 

·
Plain ole user
Joined
·
11,121 Posts
Who is the vendor? Is this a LTI replacement or an original Philips or Osram lamp? These are important questions if you want to be sure to get the right part. You should understand that you are not buying from Home Theater Shack but are being referred to another vendor through HTS.
 

·
Registered
Joined
·
1 Posts
i have the same tv and the same problem. Last night while watching a movie it sound like a fan kicked on and then the picture went to a black and green type color and the sound was still loud from the rear of the tv. I powered the tv off and waited a min or two and try'd to power it back on and all i can get it a loud humming sound from the back and no kind of picture and then it goes into stand by mode after a few mins.

thanks .
 

·
Plain ole user
Joined
·
11,121 Posts
Could be a color wheel. You have to get back there and see if that is where the noise is coming from.
 

·
Plain ole user
Joined
·
11,121 Posts

·
Registered
Joined
·
3 Posts
I am having the same problem also. I replaced the lamp and the TV still does not come on.
When I try to turn it on the green lamp led will flash slowly for 19 times, then flash a little faster 9 more times after that. What else could it be?
 

·
Plain ole user
Joined
·
11,121 Posts
What happens then? Does the lamp come one, ever see a pix? Please describe YOUR problem in detail rather than referring to others.
 

·
Registered
Joined
·
3 Posts
Sorry,
I referenced the previous email since it described the same problem. Inn answer to your questions.

1. The lamp does turn on.

2. No I still do not see a pic.

The problem in the beginning was there was no picture. I thought the green lamp led flashing indicated some kind of error code which is why I referenced it.
 

·
Registered
Joined
·
730 Posts
Sorry,
I referenced the previous email since it described the same problem. Inn answer to your questions.

1. The lamp does turn on.

2. No I still do not see a pic.

The problem in the beginning was there was no picture. I thought the green lamp led flashing indicated some kind of error code which is why I referenced it.
I had the same issue with this model no video would show up but if you looked at the back you could see the lamp lighting up. the pressure trick on the digital board brought the tv back to life for a week then i started to have issues again. you may want to try the pressure trick to see if it the powers up. if it does then you will most likely have to order the digital board since the pressure trick doesn't last forever.
 

·
Registered
Joined
·
3 Posts
Hi Ferg

It seems also that the issue could relate to a bad ballast, since the ballast is the power supply for the lamp and also is the one that regulates the voltage that goes through, I believe that there is a break in the way this ballast operates, I recommend for you to check your ballast with a service technician.
 

·
Plain ole user
Joined
·
11,121 Posts
I don't think I have ever heard of a DMO board. Samsungparts.com is the place to go to see if a part is available.
Posted via Mobile Device
 
1 - 20 of 20 Posts
Top