Home Theater Forum and Systems banner

1 - 20 of 21 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Much like many other posts out there, my unit died the other day without warning. Simply, picture froze, no noise, dead. Try to power the unit on, you can see the backlight fire up, but there's no picture or sound, the LAMP light flashes for about 30 seconds then powers down. If you go to the back of the unit, you can hear the fan running and the lamp glowing bright. Obviously, I pulled the lamp to make sure it was in tact, it was, so I reseated and closed the door. I did notice a couple small pieces of glass rattling around in the lamp housing from unknown origins.

My issue is that the advice floating around out there bounces around from replacing the lamp, checking the color wheel, replacing the DMD board, replacing the digital board, and a bad power supply. I am going to start some more simple diagnostics in the next few days and am looking for any advice on what I should be looking for to pinpoint the issue. I have a copy of the service manual and the things to check so far are lamp door switch, shattered color wheel, reset switch on the digital board, checking the DNIE chip.

Any and all help is appreciated!
 

·
Plain ole user
Joined
·
11,121 Posts
If the lamp is intact and you have never had a lamp explode in it, the glass makes me wonder about the color wheel. It is not uncommon for the color wheel to shatter because the light tunnel falls apart and when the parts of it hit the color wheel, you get a big mess. Were any of the pieces colored?

If the lamp stays lit, the lamp is not the problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
I was thinking the same thing. No, none of the glass is colored. I have also heard that you will still get a picture on a busted color wheel, just that the colors will be all screwed up or no color at all. I have no picture, no sound. I am going to start dissecting tonight and I'll let you know what I find.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Ok, I pulled the color wheel to make sure it hadn't shattered. It is completely intact. The wheel moves freely, however it sounds like it rubs when you spin it. Should the movement be completely sound free?

Second, service manual says from here to replace the DMD board. Topics across several forums out the say to replace the digital board. Is there any other diagnostics I can do to determine if the problem is the digital or the DMD board? I can not even get the unit to enter service mode. Simply a blank screen. All points in the manual aim to replace the DMD while the web says to get the digital board re-flowed. Again all help is greatly appreciated!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Can anyone help here? At a crossroads where I have read in some parts that the digital can cause the unit not to turn on, where all other places point to replace the DMD board. Any guidance on how to properly diagnose?
 

·
Registered
Joined
·
730 Posts
It shouldn't rub. also there is clear glass on the side of the light tunnel were the lamp sines thru. Make sure that didnt crack or break. These sets are known to have bad digital boards were they will try to power on and the lamp light will just flash and flash. Then the standby temp light comes on, and when you look at the back of the set. You see the lamp is on as long as the lamp light is flashing. The hlr__67w tv's are know for this issue. normaly people get the green plaid screen on std tv channels but hd and hdmi input work but in time this issue happens too.

When my one was doing this. It didn't make the samsung start up sound. That beep dadada beep thingy. It was the digital board.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
Jason, awesome! Thanks for the help. This is exactly the problem I'm experiencing.

Pardon my next question, but several resources have been using the terms digital board/main board/dmd board to talk about the same thing. You are speaking of the actual digital board with the hdmi inputs, the dmd reset switch, and the dvi-out that connects to the DMD and not the DMD board attached to the light engine? I'm not skeptical, just my findings have me all confused (especially that the service manual doesn't point to the digital board anywhere).

Thanks again!
 

·
Registered
Joined
·
730 Posts
Jason, awesome! Thanks for the help. This is exactly the problem I'm experiencing.

Pardon my next question, but several resources have been using the terms digital board/main board/dmd board to talk about the same thing. You are speaking of the actual digital board with the hdmi inputs, the dmd reset switch, and the dvi-out that connects to the DMD and not the DMD board attached to the light engine? I'm not skeptical, just my findings have me all confused (especially that the service manual doesn't point to the digital board anywhere).

Thanks again!
yes. The board with the dvi output to the dmd and the hdmi input. It also has a slot for a cable card and it also has the tv tuner.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
Jason,

Hats off to you!! Digital board ordered from SamsungParts, installed it last night and it fired right up. The service manual had such a misleading trail of diagnosis, I for sure would have ordered a new DMD board had you not jumped in. Was a surprisingly easy install, time consuming, but quite easy. I'm going to start calibration tonight. Thanks again!
 

·
Registered
Joined
·
730 Posts
Jason,

Hats off to you!! Digital board ordered from SamsungParts, installed it last night and it fired right up. The service manual had such a misleading trail of diagnosis, I for sure would have ordered a new DMD board had you not jumped in. Was a surprisingly easy install, time consuming, but quite easy. I'm going to start calibration tonight. Thanks again!
Your welcome. Like I said it's a common issue with the hlr__67w tv's.
 

·
Registered
Joined
·
4 Posts
Jason,

Hats off to you!! Digital board ordered from SamsungParts, installed it last night and it fired right up. The service manual had such a misleading trail of diagnosis, I for sure would have ordered a new DMD board had you not jumped in. Was a surprisingly easy install, time consuming, but quite easy. I'm going to start calibration tonight. Thanks again!
Hi,

I'm new on here, I have the same exact problem as you did....tv picture just froze one day and turned itself off and now when I turn it on the lamp light keeps blinking and then standby light blinks once sometimes, the lamp comes on cos i can see the light behind but then no picture or sound and tv turns itself off. I have the HL-R5667Wax/xaa.I have read all kinds of boards, replaced the lamp, ordered a lamp ballast(still in the mail) and I think your solution seems more pin point so i want to order a digital board. I went on the samsungparts site but i'm not sure which board to order can any of you guide me as to what specific board I should be ordering for my tv ? is it the LAKE PLUS,AME ASSY SUB PCB-DIGITAL BOARD/DTV MODULE or the AME
ASSY SUB PCB-DIGITAL BOARD/DTV MODULE or something else entirely ? Thanks, your help is highly appreciated.
 

·
Registered
Joined
·
4 Posts
Hi,

I have an HL-R5667WAX/XAA do you know what specific digital board I should be getting from samsungparts? Is it the AA95-03501A or D ?

Thanks
Mike
 

·
Registered
Joined
·
730 Posts
Hi,

I have an HL-R5667WAX/XAA do you know what specific digital board I should be getting from samsungparts? Is it the AA95-03501A or D ?

Thanks
Mike
http://www.samsungparts.com/Products/Parts_and_Accessories/PID-BP94-02084A.aspx?model=

This says its new on ebay and you dont have to send back for a core plus it has free shipping.

http://cgi.ebay.com/BP94-02084A-Samsung-Digital-Board-New-/150610354900?pt=LH_DefaultDomain_0&hash=item231113a2d4

if you look on samsungparts.com it says this board works with HLR4667W, HLR5067W, HLR5667W, HLR6167W, HLR6767W

mine has this board and its a HLR5067WAX/XAA
 

·
Registered
Joined
·
4 Posts
Thank you very much Jason, it's sincerely appreciated. Hopefully this is the part i need because my symptoms are pretty much the same...I may need to return the ballast which is already on it's way...I'll keep you guys posted.
 
1 - 20 of 21 Posts
Top