Home Theater Forum and Systems banner

1 - 4 of 4 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi all.

I am very impressed with the many intelligent posts in this forum. The helpfulness of so many people is a very nice to see.

I have a very interesting problem . . . or I should say situation.

After pulling out the projectors and draining the coolant, since the original problem was that the screen was mostly green, I made an interesting discovery. Somehow the color lens on the top of the projector for the Blue lens had lost all the pigmentation. I have been searching the web high and low, but I cannot find that part. , I can't even find any type of schematic that will show the part name or part number.

If anyone knows this information, I would greatly appreciate it. I would prefer to just find a replacement blue colored cover / lens instead of the the projector assembly.

Thank you in advance

Daigo3d
 

·
Plain ole user
Joined
·
11,121 Posts
What makes you think that the lens has "lost its color?"
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #3
When I drained the coolant, I removed the top cover that had the color. The green and red colors were there, but the blue looked like it had been scraped off, and was clear.
 

·
Plain ole user
Joined
·
11,121 Posts
I suspect that the blue had no color to start with. I do not recall anything but a clear lens on the blue. The coolant contamination is usually only in the blue and leaves a hard residue on the back of the lens. This is probably why you think it was scraped off. Be very careful getting it off. You can soak it in isopropanol to losen it. Sometimes just some soap will get it off if not to encrusted.
 
1 - 4 of 4 Posts
Top