Home Theater Forum and Systems banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm new to forum so I just want to say BIG HELLO to everyone out there.
After 8 years of great,clear, high-def service my Pioneer SD533HD all of the sudden won't turn on. I had no problems with it whatsoever, not even once, no blown fuse, no convergence issues etc. Storm was coming so I unplugged the power cord and I can't turn it back on. Nothing, not even standby LED is on, no pops when plugged in. I checked all 5 fuses and they are good. Also power runs thru the unit. I can go "easy way" and buy a new TV but it bothers me that there was no sign that this is coming, the picture was great, HD worked fine so I'm gonna go all the way and try to fix it. I'm open to every advice and THANK YOU for any responds.
If anyone knows what could cause that problem, please help me out.
 

·
Plain ole user
Joined
·
11,121 Posts
The most common problem, by far, with Pioneer RPTV was always bad solder connections. Your problem might be something else, because they usually fail intermittently when solder joints are the problem. I always start by testing the power supply with a completely dead set, but if you are not familiar with troubleshooting swtiching power supplies, you might want to try to find a professional to service it.

Look for a Pioneer ASC or a NESDA servicer in your area if you have someone else do it. The manuals for these are expensive and somewhat harder to find than many others and if there is something beyond the obvious wrong, it will likely require some documentation and experience with this series of sets.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top