Home Theater Forum and Systems banner

1 - 10 of 10 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
It's always the dumb little things.

In my case, I've got a mac air with Mavericks, the v 22 beta of REW, an HDMI dongle on the display port, a cross spectrums calibrated USB mic, and a rat shack meter..... and I can run a nice sweep of the room.

BUT

It's with all speakers playing.

For whatever reason, I cannot figure out how to output to and measure a single channel at a time.

I'm sure it's a simple toggle or drop down somewhere and murphy's law dictates that I need to publicly humiliate myself by admitting that I cannot find it.

Hints?
 

·
REW Author
Joined
·
6,711 Posts
With the Java sound drivers the test signal is placed on both channels of the selected output (left and right). You might be able to set the volume for one channel to zero using the Mac's audio controls.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #3 (Edited)
With the Java sound drivers the test signal is placed on both channels of the selected output (left and right). You might be able to set the volume for one channel to zero using the Mac's audio controls.
Ah, I see. So using Soundflower still provides more options (ie, could easily choose a single channel from any of my 7.1 channels).

BTW, it's an awesome piece of software and I'm not trying to look a gift horse in the mouth. Just want to make sure I'm not approaching it in a sub optimal way, and of course pushing in the direction of my ideal use cases....
 

·
Registered
Joined
·
133 Posts
Discussion Starter #4
After some more testing, it is not possible. (Or at least not possible for me, after spending the day trying various scenarios and configurations.)

I need to go back to unplugging all the speakers except the one I want to measure, to figure out why my room with a half dozen bass traps and Antimode is still measuring like this.

That however will wait for another day.

 

·
Registered
Joined
·
22 Posts
I also have to make lots of measurements with single channels and both channels, and mic positions. I have to turn on/off my active speakers many times... my output device is a hiface that has no volume control.

Sound flower is unsuitable for this purpose as it routes the output sound to the input of an application. I did not see an option to mute a channel in REW. The external mixer (audio MIDI setup in mac os x) does not allow to change volume to the hiface.

Edit: Issue solved!

1. Install sound flower and AU Lab as described here: http://www.dctrwatson.com/2011/06/os-x-system-equalizer/

2. In AU Lab create a new document unchecking the "Link Channel Groups" box and and moving the R box to "Unused Channels". Save this as "left channel" doc.

3. Repeat step 2 but moving the L box to "Unused Channels". Save this as "right channel" doc.

4. Close AU Lab.

Now, setup in REW soundlfower as input and, as output, the same output device as that specified in steps 2 and 3. Before measuring, open only one of either documents created in steps 2 and 3 (never have both documents opened as the system can send strange sounds!) and the selected channel will be only one playing the sound of REW. If you want both channels, clearly do not open the documents.
 

·
Registered
Joined
·
22 Posts
Unfortunately the above method produces clicks and pops during the sweep (on Yosemite), so it is not reliable the measurement thus obtained :(
 

·
Registered
Joined
·
4 Posts
I think I did it, it was time ago :)
Meanwhile I managed to find out what the problem with the clicks is.
I'm using Yosemite and it seems that AU Lab has a problem with that. I have switched to Hosting AU and it works perfect! No more clicks. And I'm running Soundflower at 24/96.
So you just have to replace AU Lab with Hosting AU, works great. I presume you can find your way around that software.
 

·
Registered
Joined
·
22 Posts
Hosting AU sounds useful, thanks, I will try it next time.

Cheers
Roberto

Meanwhile I managed to find out what the problem with the clicks is.
I'm using Yosemite and it seems that AU Lab has a problem with that. I have switched to Hosting AU and it works perfect! No more clicks. And I'm running Soundflower at 24/96.
So you just have to replace AU Lab with Hosting AU, works great. I presume you can find your way around that software.
 
1 - 10 of 10 Posts
Top