Home Theater Forum and Systems banner
1 - 2 of 2 Posts

·
Moderator Emeritus
Joined
·
3,772 Posts
Discussion Starter · #1 ·
I just had an issue with my PC booting very slowly and thought I would share the answer, or at least the answer in my case.

I'm using a rather old motherboard by current standards (a Gigabyte P35-DS3L), but it's all I need for now.

I had some problems not long ago that gave me a fright thinking the motherboard might be going bad, but I finally traced the problem to a malfunctioning USB hub. After that was swapped out everything seemed to be fine again.

I started experimenting using XP's Stand By mode instead of totally shutting the system down. It seemed to be working well, but later I learned it actually made the system unstable after 3 or 4 days (at least with my hardware).

After using Stand By for awhile I noticed that my system was taking WAY longer to boot than it used to. I don't know what changed, but it went from booting in about a minute to taking about 4 minutes!

To make long short, I found that the problem was that my BIOS was checking all the external USB drives connected at boot since they were in the BIOS boot list. Physically detaching all these drives (I currently have 3) before booting was a solution, but I knew there had to be a better way. Again to make long short I discovered that there is a setting in my BIOS called "Legacy USB Detect", I disabled that and now everything is working great (all USB devices work just fine) and my system boots faster than ever. This was a BIOS issue and not an OS issue.
 
1 - 2 of 2 Posts
Top