Home Theater Forum and Systems banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all,

I've plugged my Sony STR DN-1030 in and after it started up a notification showed reading "USB FAIL". Online and the receiver's manual state that an overcurrent from the USB port was detected, but the weird is I didn't connect any device.

Does anyone have an idea of how I can solve it? Can I disable the USB port? I've tried to connect a cable to the port but it didn't help...

Thanks
 

·
Registered
Joined
·
349 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks! that was my intuition as well, but as I said no device is connected even though the error message appears. Is there anything I'm missing?
 

·
Registered
Joined
·
145 Posts
Does the error prevent you from using any AVR functions? If you just get the error, but everything else works fine, I would ignore the error if the USB port is not needed/not used. There could be a component failure in the USB interface... so the USB port may not be working now. Or the circuit that monitors the port has a failed device and the port itself is fine. If you do need the USB port to work or if there are AVR functions that don't work, your only choices are a repair or replacement. Since this receiver was made in 2012 or 2013, it may be tricky to find a service center that still services them. The cheapest fix might be to buy a cheap used 1030 that is maybe missing the remote or the case is damaged... those would make the beat up 1030 pretty cheap. When it arrives, you (or a local electronics repair shop) can disassemble the old one, remove the circuit board with the USB port and swap it with the one in your 1030. If you aren't into DIY for electronic problems, it may be easy or impossible to find a local repair shop that can do the swap for you. It just depends if you happen to have the right guy nearby who is managing to keep his business going against all odds.
 
1 - 4 of 4 Posts
Top