Home Theater Forum and Systems banner

Soundblaster Live! 24-bit USB External Setup

65527 Views 114 Replies 30 Participants Last post by  JohnM
REW (SB Live! 24-bit external)


I have a Creative 24 bit external soundcard but have been unable to calibrate it despite messing with all the various settings there was always some feedback. The only way I can get a normal looking curve was to use the internal card as output and the external card as input. This gave me a calibration curve similar to that for an internal card.
I then tried a sweep for the sub but it seems with limited success :scratch:
I've spent all day on this and achieving very little so far. Can anyone help?

1 - 20 of 115 Posts

Do I just enter the figures in to the REW somewhere?
Simply copy the calibration data into notepad and save the file as rs.cal in any directory you wish.

Then start the REW program and under the pull-down METER, select LOAD METER/MICROPHONE CALIBRATION FILE.

You then enter the location of your XXX.cal file and that's it. The next time you start REW it will tell you that the cal file is loaded.

Did you check the thread above where it says,

'Just above the slider on the far right of the SB Surround Mixer box there is REC. with a small symbol just above the red slider.

Check that the vertical writing alongside the slider shows "Line-in/Mic-in" instead of "What you hear"

Did that not make any difference?


You are likely setting an internal loopback monitor in the soundcard itself and so the input line is not functioning.

When REW can't see an input it will increase the level to max to try and correct the situation and the end result is the error you are getting.

This is the standard error people make with the soundblaster cards.

Did you read this thread over and also this thread over?

Perhaps best not to post in this Sticky thread. Perhaps start your own thread if you still have problems.. :)

See less See more
so can you explain the exact wire and connectors that I will need to connect the CM 140 to the soundblaster and then to the Pre Amp, in my case a Stereo system. The output on the CM 140 say's it has a 1/8 in output. Do I use a 1/8 in stereo plug or mono plug to the sound card from the CM 140. From the output of the sound card do I use a 1/8 in. stereo plug to with RCA's to the pre amp?
The CM-140 uses a standard 3.5mm (1/8") mono plug.

The SoundBlaster 24bit external uses standard 3.5mm (1/8") stereo jacks that must be broken out with a stereo Y adapter to two mono like this:

Text Line Font Parallel Diagram

See less See more
You need two 'stereo to mono' adapters like this:

Cable Technology Electronic device Electronics accessory Auto part

To plug into both the LINE-OUT and LINE-IN stereo jacks as shown with the red arrows in this picture:

Text Line Font Parallel Diagram

Now you have 'broken out' the right channel of the soundcard.

Then you need a mono to mono 3.5mm (1/8") male to male cable to go from the Galaxy to the red mono right channel LINE-IN.

Then you need a mono 3.5mm (1/8") male to RCA male cable to go from the red right channel LINE-OUT to your receiver AUX input...

See less See more
The red line in the card calibration. It dosn't look anything like examples given in other threads. Any ideas where I am going wrong
Yep, notice that your calibration file for the soundcard is the mirror image of the meter calibration file? It means you have an internal loopback turned on in the card itself and so you're simply reflecting the opposite of the meter file.

You have to find where you have the 'monitor mode' turned on and get it off.

Check the Windows mixer playback mode and see if Line-in is selected. If so, it must be off in playback, but on in record...

I have left output and input looped for reference and I loaded the mic calibration file. I checked the scope and it looks good still. Is that an acceptable connection?
Generally we don't recommend using the digital output of the soundcard, since you aren't able to accurately create and use a soundcard calibration file. Using the new alternate method of the left channel calibrate cable isn't a good idea either, since it will compensate for the soundcards analog driver section that you aren't using.

It would be better in my opinion to use no left channel calibrate and no soundcard calibration file. It won't be as accurate as using the analog output and input, but if it's a decent card and you assume the digital response is good, then go ahead.

I would try and get the analog working. No reason it shouldn't be fine....

I purchased this sound card specifically because the REW Help claimed that it works.
I believe that the Help files are fairly specific that it doesn't work with VISTA, where it says:

Note that the Creative software does not function properly under Windows Vista, the card can still be used but only by loading the Vista-compatible drivers from Creative's website and using the Windows mixer, do not install the Creative software under Vista..

With respect to the Mac, I believe that Leopard OS has proved to work better with this card.

You're right. I got things to work today just fine

So, in the Settings page, do you see the SoundBlaster card in the Output Device and Input Device selection pulldowns? Previously, REW had no access to the card and Default had to be chosen.

If you are indeed able to select the SoundBlaster card now, then is the Wave Volume and Output Volume and Input Volume not grayed out anymore? Do you have control of these parameters in VISTA?

I cant get the output and input any closer together than about 8dB
I don't see a real problem there. I might suggest to simply use the left channel calibrate method and then you don't go through the soundcard cal routine.

Connect a cable on both left and right channels with the left channel calibrate checkbox ticked and take a measure and see if you get a nice flat line...

I just bought a Toshiba and was about to head out to buy the Soundblaster. Hopefully you got it to work?
Perhaps you might consider a different soundcard.

It's very easy once you think about it.
Not sure I really understand the fix. The monitor capability is an internal loopback in the card itself.

Well, I've yet to see any other recommendations on USB soundcards that sounded too great.
Well, I guess you didn't read my review last week of the Turtle Beach Audio Advantage SRM external soundcard. I really like it, and it works perfect with VISTA. No one seemed very interested in the review though, I'm guessing not many people use Vista on a laptop.

It also sounds like I can use the card just fine without the SB software.
Why do you assume that? I don't consider looping cables etc to trick monitor mode as working correctly. Do you really want the monitor mode on permanent when you use the SB card? It seems this may be a problem.. I sure wish someone would tell us if they have this working properly with Vista and REW. :)

Mostly, it seems to be the most widely used external card for REW users
For XP............................

I'm not going to be using this for much beyond my initial setup and tweaking of my speaker placement
It doesn't hurt to have an external USB card around that will output and input both digital and analog signals.

maybe I'll install XP on this laptop instead of this piece of **** OS.
Well, I don't think that's the answer. Vista is the operating system that Microsoft is offering right now and there will be no further support of XP at some point. People will have to get used to Vista.

There have been problems with this card not working with Vista, until recently lalakersfan34 reporrted that now it does work.

I've never personally tried the card. I only know what has been reported from threads like this.

It may be just fine now. It would be interesting to know if the card now works with VISTA combined with the SoundBlaster supplied drivers, along with no jiggery pokey required to make it work......

Were you using a full range signal to adjust the levels in the settings page and then using a full range sweep to carry out the measure?

There exists in REW, a sanity check with levels and bandwidth. If someone uses subwoofer bandwidth limited pink noise to set up the levels in the settings page, and then goes to the measure page and sets an upper limit of 20KHz as the measurement sweep, then the levels check on this screen will fail the test (obviously).

Does the Settings page Level check and the Measurement page Level check match and give you a good-to-go report? :)

is that volume high warning an issue or not?
Simply look at the Scope Tab after the measurement and check for clipping. If no clipping... you're good.

The scope looks fine.

Why is the measure at 105dB and not 75dB?

Using two cards is not a great idea. You would rather use the single card used for Default when dealing with Vista. But, I guess if you can force it to work, why not.

There are coax to optical converters available that you could use, but I'd probably look for the long optical cable if you went that route.

Clear the Mic/Meter calibration file. It shouldn't be loaded when you do the soundcard calibrate routine.

Further problems should probably be directed to a new thread. :)

I managed to get the card working fine, on both the rear and front channels, but the volume is at least 30% reduced from XP. Im going crazy, especially since i tried everything! Help
Not many people have had luck with this card and Vista.

So, you have it working. Did you do a soundcard calibration with it and the result was successful with respect to setting up the levels?

Are you able to control the levels with the Vista Playback and Recording Devices screens on their Levels tabs? (access these with a right click on the speaker icon in your Desktop System Tray).

I need help
OK, we can go through it step by step.

First you need to do a soundcard calibration. This involves creating a file that will be saved in your computer to compensate for any response problems with the soundcard. It will render the card flat.

To carry this out you need to remove all cables (except the USB cable of course) and then connect a cable from the right channel of line-out to the right channel of line-in. The line-in and line-out (a.k.a front) are stereo 3.5 mm phono jacks, so you'll need a set of adapters that splits out the right and left channel of both line-out and line-in before you connect the loopback cable.

From this thread you'll see there are a few types of these break out adapters such as this one or this one.

Let me know when you get set up with the loopback in place.

1 - 20 of 115 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.