Home Theater Forum and Systems banner

1 - 9 of 9 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Hello,

what would cause audio signal from HTPC (over HDMI) be identified as MULTI CH IN 7.1 even for stereo or mono material ?
It happens whenever I play music in any of the players I have (foobar2000,wmp, winamp).
is this an indication that ASIO4all is not set up properly and that kmixer is still engaged?
I have no issues bitstreaming movies.

windows 7, asio4all, shark007 codecs, radeon HD6570 HDMI, Denon 4311, not sure what else maybe relevant.

thank you
 

·
Registered
Joined
·
876 Posts
Hello,

what would cause audio signal from HTPC (over HDMI) be identified as MULTI CH IN 7.1 even for stereo or mono material ?
It happens whenever I play music in any of the players I have (foobar2000,wmp, winamp).
is this an indication that ASIO4all is not set up properly and that kmixer is still engaged?
I have no issues bitstreaming movies.

windows 7, asio4all, shark007 codecs, radeon HD6570 HDMI, Denon 4311, not sure what else maybe relevant.

thank you
Check your speaker settings in windows 7. Change it over to 2.0 or 2.1 stereo.Try double clicking on the speaker icon by the clock or find it in the control panel. It may take a little hunting and pecking in the speaker/volume settings to find; but it is there.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3
Check your speaker settings in windows 7. Change it over to 2.0 or 2.1 stereo.Try double clicking on the speaker icon by the clock or find it in the control panel. It may take a little hunting and pecking in the speaker/volume settings to find; but it is there.
Thank you for the reply.

It turns out that windows speakers settings only affects DS output (at least in foobar2K ).
when ASIO is used I still end up with receiver identifying it as 7.1. And of course when I set windows sound to 2 channel all my multichannel tracks are downmixed to stereo when DS output is used.

Perhaps it was not clear from my initial post, the stereo signal is not matrixed. As far as I can tell only front two speakers reproduce sound. Yet the receiver is locked in multi ch in 7.1 mode.
The reason I am concerned is that in 7.1 input mode all DSP niceties such as Dolby PLII are disabled.

I guess for now i can use DS output for stereo and ASIO for multichannel.
 

·
Registered
Joined
·
1,208 Posts
I love that WASAPI plugin..... have you tried using the 7.1 analog> multi channel analog input instead of HDMI ?? you may be surprised. My 7.1 analog is really superior to the HDMI SQ , not that the HDMI SQ is bad.....
 

·
Registered
Joined
·
876 Posts
I love that WASAPI plugin..... have you tried using the 7.1 analog> multi channel analog input instead of HDMI ?? you may be surprised. My 7.1 analog is really superior to the HDMI SQ , not that the HDMI SQ is bad.....
Excellent point, some source players have better DACs than the Receiver/Processor; espeically if you own on of those nice special edition Oppo players.
 
1 - 9 of 9 Posts
Top