Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I have a yamaha receiver amd almost always have it set to straight. I upgraded to windows 8.1 from 8. Before the upgrade stereo would show 2 channel and maybe the sub too on the little display for what speakers are showing inputs. After the upgrade, the receiver always displays 5.1 channel. Amazon prime sounds like upmixed stereo. My surrounds have dialog and all. Playing music from media monkey shows 5.1, but the sound is only coming out in stereo. Anyone else experiencing anything like this after the upgrade? What gives?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
I've been digging around quite a bit. Seems like it is an Nvidia driver issue (I have the GTX 660). I updated the graphics drivers at the same time I made the change to 8.1. I uninstalled the HD audio driver and windows would not let me install a new driver until I rebooted. Windows reinstalled it for me during reboot before I had the chance to change it. I went to change the driver to an older version and windows informed me that it thought that I already had the best driver installed, thank you very much. I then asked window to give me a choice of what drivers I could use. It gave me 3 choices. I picked one that still said Nvidia, but was a little older.

Now when I play VCL, my receiver properly shows me that the audio coming to it is stereo when I am playing something in stereo. This allows me to make changes to the audio in my receiver if I want simulated surround.

Amazon prime instant is still playing a terrible version of surround sound no matter if the video says SD or HD. So I think this may be a separate issue.

I am hoping Nvidia fixes this. If not I may consider using the output from my motherboard or purchase a sound card. I hate to make either of those changes, but I need to be able to control my audio!
 

·
Premium Member
Joined
·
404 Posts
If it is indeed an Nvidia problem, after you correct your HDMI driver do this:

Check your audio settings in Windows 8.1 and check out your properties on your default audio driver. Configure your default the way you would like it to run.

After that - look at the properties of each media player that you use (Media Monkey, WMP, etc.) and then go into the sound properties of those and set them how you would like them to play.

Hope this helps.
 
1 - 3 of 3 Posts
Top