Home Theater Forum and Systems banner
1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I found a JVC SP-THD5W 200 watt sub that I never connected to anything. I need an amp for the sub because my stereo amplifier (JVC RX-5020VBK) requires a powered sub woofer. I was looking at the sub amps on Amazon for 100w, 200w and wondered if this is my best selection (powered mono sub amp for sub woofer). I was looking at the boxed and un-boxed ones, but once again, wondered if I have a better choice to hook my sub up to my stereo. Also, do I need a 200w if the sub is 200w? The unit is in the garage and setup with 5 speakers (5-1) and a sub would be nice.

Thanks!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Hi guys, thanks for the input. I agree, 100 watts should be fine. The sub amp has a terminating impedance of 2~8 ohm. I don't turn up the power much since it is in my garage and the sound stays in the garage.

I just finished replacing my OEM stereo system in my Town Car with JVC equipment, but left the factory speakers in. They are JBL speakers and the only speaker that has gone bad is the sub. Got tired of not being able to listen to my android in my Town Car. I did my Cougar a few years ago with JVC and Blaupunkt equipment. (just sharing)

Thanks again for the feedback!
 

·
Registered
Joined
·
1 Posts
Hi guys, thanks for the input. I agree, 100 watts should be fine. The sub amp has a terminating impedance of 2~8 ohm. I don't turn up the power much since it is in my garage and the sound stays in the garage.

I just finished replacing my OEM stereo system in my Town Car with JVC equipment, but left the factory speakers in. They are JBL speakers and the only speaker that has gone bad is the sub. Got tired of not being able to listen to my android in my Town Car. I did my Cougar a few years ago with JVC and Blaupunkt equipment. (just sharing)

Thanks again for the feedback!

What year Cougar do you have? I have an '88 5.0L with more then a few mods.
 

·
Registered
Joined
·
189 Posts
Good old speed density EFI. My 83 Mercury Grand Marquis LS had CFI...central throttle body fuel Injection. I had 4 MTX RT2154's in a isobaric BP4 running off a Autotek 7300BTS at 1 ohm.
 
1 - 6 of 6 Posts
Top