Home Theater Forum and Systems banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
My Samsung HLP-4663W 46'' Projection TV is broken at 3700 hours. I changed the lamp and it worked for a few days then developed a new problem.


Sometimes after I plug the power cord back on, it restarts itself several times then the lamp starts. However, the picture will stay for only about a minute then disappear. The sound is still there but TV makes no responses to remote or the buttons on the TV. Can't power off. Have to pull the power cord to shut it down. When the pictures disappear, the lamp is off.

Sometime after I plug the power cord, it restarts several times then does nothing but flashes the 3 lights on the power button on the front of the TV.

Any ideas? Thanks a lot in advance!
 

·
Plain ole user
Joined
·
11,121 Posts
Look for the threads on the digital board problems. You may affect your symptoms by adding pressure to the DNIE chip. It may improve or it may get worse, but at least it will help you isolate the problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4 (Edited)
it seems that the issue could be also with the pcb or power supply.
Thanks for the reply. Yes, you are right. I bought a service manual for the Samsung 4663wa and tested the voltages and found out the ballast is broken.

Updates: I now believe the service manual has mistake. It tells me to check the voltages on the cables linked from dmd board and power supply if they are good then the ballast is broken. I put a new ballast in but it doesn't solve the problem.
 
1 - 4 of 4 Posts
Top