Home Theater Forum and Systems banner

1 - 14 of 14 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I finished up my speakers build and was anxious to test out REW. I read through the Getting Started guide.

My system is:
Laptop with Windows 10
Denon AVR
UMIK-1 microphone

REW installed fine. I am able to import the mic file. I installed the ASIO4All program (2.13).

I am running Win10. I am pluged into my Denon AVR and my UMIK-1 is plugged into my usb port.

In Win10 it shows my Denon AVR as the default playback device, and the UMIK-1 as the default recording device. I was able to set all the configurations up as per the guide.

But when I start REW and go into settings either the Output dropdown shows the correct items OR the Input shows the UMIK-1 --- but never both!
If it shows the correct Output and I reload, then it will show the correct Input but not the Output.

If I click on the Configuration button, it shows everything there that it is supposed to, but one or the other will show as idle.

Not sure where to go from here.

I have uninstalled and re installed both REW and ASIO twice. I tried rebooting the computer multiple times.

Any help would certainly be appreciated.
 

·
Premium Member
Joined
·
1,400 Posts
ASIO4ALL can appear to be temperamental.

One must make sure that within it ( ASIO4ALL ) all the WDM Devices ( one wishes to use ) are activated ( Triangles & Squares are lit in blue ) as seen in the following picture .



And ( of course ) one must then choose "ASIO" ( as the driver type ) within REW's preferences window to actually see these devices ( as possible choices ).

:)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Thank you for your reply. The problem is that I cannot get them to activate.
The Denon and the UMIK-1 are listed in the devices. However if the Denon is active then the UMIK-1 is not. And it will not activate by double clicking on it. It remains idle.
Then if the UMIK-1 is active, then the Denon is not. And again I cannot get it to activate by double clicking on it.

While this is going on, both are recognized as default in Windows
 

·
Premium Member
Joined
·
6,711 Posts
Someone with a similar issue contacted me recently, they made it work by disabling the onboard sound:
I had to go into the playback and recording devices and manually disable both the Realtek High Definition Audio Speakers and the Realtek High Definition Audio Microphone. After this was done, I was able to activate the HDMI and UMIK in the ASIO4ALL's device list.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
Someone with a similar issue contacted me recently, they made it work by disabling the onboard sound:
Didn't help. I disabled everythinhg except the Denon for output and the UMIK-1 for input.
Results are the same. Sometimes the Denon is available to output but not the UMIK-1 for input.
Other times the UMIK-1 is available for input, but then the Denon is not for output.

Could this be a Win10 problem?

Would realy like to get this going.

George
 

·
Premium Member
Joined
·
6,711 Posts
No, there is no general Win 10 issue with ASIO4All. You are in ASIO4All's advanced mode, right? So you see the info on the RHS as in Earl's screenshot? When not in advanced mode I've found ASIO4all doesn't like input and output to be on different devices, but it's fine if advanced mode is selected (by clicking the wrench). Probably also worth checking the Denon is configured for 48k operation, same as the UMIK.
 

·
Premium Member
Joined
·
1,400 Posts
Didn't help. I disabled everythinhg except the Denon for output and the UMIK-1 for input.
Results are the same. Sometimes the Denon is available to output but not the UMIK-1 for input.
Other times the UMIK-1 is available for input, but then the Denon is not for output.

Could this be a Win10 problem?

Would realy like to get this going.

George
While you haven't actually articulated that you're using HDMI between your ( unknown model of ) computer and your Denon AVR, I'm making this assumption since the word DENON is apparently (dynamically) appearing within device info boxes (as seen) in your computers sound control panels.

My guess is your situation is caused by yet another wrinkle (problem) of the common HDMI handshake protocol ( getting confused > hence the toggling of "available devices" you are seeing within ASIO4ALL ) .

A Possible Solution; In case you are unawares, there is a "best practice" for powering up all devices connected together via HDMI ( one can google for this info HDMI Power Up Sequence ) but it essentially states that the furthest away device receiving an HDMI signal gets powered up first ( & then the next device moving towards the signal source & so on ) until one arrives at the signal source ( which is the computer in your case ) .
- There are a couple of caveats to this order of power up ( mostly involving 2 audio chnl TV monitors ).
- Observing the proper power up sequence helps maintain the proper auto-handshake & process ( signal & device recognition ) that HDMI goes through.

REW & ASIO4ALL are typically innocent bystanders in all this HDMI mayhem ( merely reporting what they discover is available, whether expected or not ).

:)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Well I got it to work finally. What I found may be helpful to put in the guide.
When setting up the windows Playback and Recording devices ---

On the Recordings Tap click on UMIK-1, Click on properties, Click on Listening.

In the box "Playback through this devices" Change from Default Playback Device" to your specific device. In my case it was "Denon AVR"

Once I did that I was able to complete the setup. Now for a lot more studying on taking measurements.

Thanks to all for you support.
 

·
Premium Member
Joined
·
1,400 Posts
Hi George,

Glad you got your situation sorted out .

What I'd like to know is whether or not this is a another new Win10 wrinkle that now needs to be kept track of ( ie; plugging in the UMIK-1 mic auto-selected it as the default output device )

- or -

Was this a conscious selection that you had previously made / perhaps not understanding the consequences of choosing the UMIK-1 for output .

:scratch:

I'm still on Win8.1, so I can't test out all the various scenarios .

EarlK
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
Hi George,

Glad you got your situation sorted out .

What I'd like to know is whether or not this is a another new Win10 wrinkle that now needs to be kept track of ( ie; plugging in the UMIK-1 mic auto-selected it as the default output device )

- or -

Was this a conscious selection that you had previously made / perhaps not understanding the consequences of choosing the UMIK-1 for output .

:scratch:

I'm still on Win8.1, so I can't test out all the various scenarios .

EarlK
I never chose UMIK-1 as the output. It was always selected as the input.

Whether this is a Win 10 thing I dont know. What I do know is that previously I had the Denon AVR as the default output, and the UMIK-1 as the default input. I even went so far as to disable ALL inputs and outputs other than those two. But it wasn't until I decided to try what I did on the Microphone Listening tab that it worked for me.

George M
 
1 - 14 of 14 Posts
Top