Home Theater Forum and Systems banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So I have some Pro Studio ps412-1 speakers I bought off craiglist and I can't find much about them anywhere online. I've had them for about a year and the tweeter and mids on them just recently have stopped working all together. I'm assuming the drivers failed.

I opened them up to see if I could find replacement tweeter and mid driver models online and I couldn't find much of anything. They seem to be some sort of sony brand. Tweeters 4 ohm and mids 8 ohm. These are the pictures of the backs of the parts that have stopped working:

Technology Auto part Rotor Machine Tool accessory


Metal Tool


Auto part Metal


Green Circle Eye Metal Gong


What tweeters and mid drivers do you think would work best for this setup? As long as they are flush with the plastic as shown with the photo I don't think size will be much an issue because the opening in the speaker housing is pretty large. I just don't want them to get blown out again and would like to replace them myself.

Can you guys offer any guidance as to where I should look for replacements or what kind of replacements I should purchase?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
I'm not home to check them at the moment but if they are in fact blown you're saying i more than likely would have to replace the crossover as well? How difficult is it to replace a crossover?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Could I just find drivers that will work with the crossover and rig the housing to work with whatever size they turn out to be?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
So interestingly I just checked the drivers and they all seem to be working....Where do I look now? Bad crossover?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Alright I opened up the back of the speaker and I think I found the problem. The capacitor seems to have gone bad. The wire in the first picture is connected on the left terminal and just kind of hanging there disconnected from everything. I'm assuming it's supposed to be hooked into the capacitor.

That is the wire that is supposed to be hooked into the tweeter and the white wire shown in picture 2 is supposed to go into the mid. Both aren't working. I can't see any other capacitors that look like they have gone bad so can the one that went bad prevent both the mid and tweeter from working?

Also there's an extra set of blue wires and I'm not sure what those are for.

Light Wire Technology Electrical wiring Electrical supply


Wire Electrical wiring Light Lighting Cable
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Cross referenced with the other speaker that just recently quite working. The blue wires run to the tweeters. I'm assuming that the above setup was done as a workaround because something went wrong that couldn't be replaced and probably just happened in the second speaker. I'll probably have someone look at who knows what they're doing and go from there.
 
1 - 6 of 6 Posts
Top