Home Theater Forum and Systems banner

1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I am having a hell of a time getting my UR22 mkII setup with REW. Looking for suggestions.

Equipment: Steinberg UR22 mkII, Dayton EMM-6, Asus Laptop, Yamaha AVR.

My issues start right at the beginning with the soundcard calibration. I have my UR22 hooked up with input 2(R) looped to line out 2(R); input 1(L) is unhooked from the mic, and line out 1(L) is TRS to RCA into my AVR. The UR22 is then connected via USB to my laptop.

I have loopback enabled, and mix set to mono in the ASIO settings. The input/output settings are show in the attached calibration preferences screenshot.

The plot that is generated for this calibration looks far too smooth for what I've seen other's post, and I do not think it is correct. Attached is the screenshot "1.14 soundcard calibration lineout 2 to input 2". Also there is an oscillation at the highfreq that looked off to me.

Am I setting the UR22 up correctly for this procedure?


I've read some people recommending using the headphone out, instead of the lineout for the loopback. When I do that I get nearly a perfectly flat plot, that can't be right either.

I'm not sure what I'm doing wrong. All the setup tutorials I've read will often contradict each other with how this loopback is to be setup, and few provide diagrams. Either way I can't seem to get reasonable results any way I try it.

--------

So I've also read that calibrating the soundcard isn't essential, and that you can do measurements without it, since the calibration is often 1dB or less corrections. When I make a room measurement with the microphone attached, I get an extremely flat room response, which I know is not accurate. This is attached as "1.14 room measurement no soundcard calibration".

A bizarre thing is- if I have that last plot up, then I open the preferences menu and rerun the soundcard calibration measurement (without saving the calibration file mind you), the existing room plot will change to the attached screen shot "1.14 room measurement CHANGE"- without rerunning the room measurment. That I REALLY don't understand. If I run another room measurement, it reverts back to the original plot.

I have been fiddling with this for a few hours each day all weekend, and I can't seem to find the errors I'm clearly making. Any suggestions would be greatly appreciated. All plots are with no smoothing.
 

Attachments

·
Registered
Joined
·
15 Posts
Discussion Starter #2
Additional info

I just noticed that in that preferences screenshot, the "invert" option was selected- I had unchecked that before any measurements.

Also, I have the "MIX" knob on my UR22 set all the way to DAW. I read on another post here in Home Theater Shack that that was preferred, but not sure on that.
 

·
Premium Member
Joined
·
6,711 Posts
I have loopback enabled, and mix set to mono in the ASIO settings
Do not enable loopback, that is creating a feedback loop inside the ASIO driver. The cable connection you have made from output to input is the loopback.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Interesting. I will change that and try again when I get home this evening.

Thank you! Hopefully that does it for me.
 

·
Super Moderator
Joined
·
9,258 Posts
If you can’t get a good loopback, don’t worry about it, unless you’re interested in timing measurements, but make sure you’re using a 1/4” TS plug in the input, not XLR.

line out 1(L) is TRS to RCA into my AVR
Didn’t know anyone made such a cable, as it’s pointless. If that’s truly what you have, use a TS to RCA cable instead.

Regards,
Wayne
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
If you can’t get a good loopback, don’t worry about it, unless you’re interested in timing measurements, but make sure you’re using a 1/4” TS plug in the input, not XLR.
I am using a 1/4" TR plug looping from input to output. Only XLR I have is coming from the mic.

line out 1(L) is TRS to RCA into my AVR
Didn’t know anyone made such a cable, as it’s pointless. If that’s truly what you have, use a TS to RCA cable instead.
I guess I should clarify- I didn't have a TS to RCA cable available, so I used a 1/4" TRS to 1/8" to TRS adapter, 1/8" TRS to L/R RCA cable, into the front RCA input of my AVR. I had previously been using the HDMI out on my laptop, but decided t bypass the laptop entirely while trouble shooting. So the only connection the laptop has is the USB to the UR22.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
I unchecked the loopback option in the ASIO Control Panel, re-ran the sound card calibration and got different results depending on if the microphone was connected. For some reason I was under the impression that it didn't matter if the microphone was connected for the sound card calibration.

With the microphone connected, I get a clipping error. I can't seem to get the test to run without clipping. To get the levels to -12dB, I have to have either the input gain, or the output gain maxed out on my UR22. This is with my source outputting the test tone at 85dB (verified with Radioshack digital SPL meter).

With NO microphone connected, I get a low signal level warning. The respective plots are attached.

This is with all other signals and setup the same as before. I would like to do some timing measurements in the future, so I'd like get it sorted out now, but I'm not sure where my issue still lies.
 

Attachments

·
Premium Member
Joined
·
6,711 Posts
To do the soundcard calibration the loopback cable needs to be on the measurement channel, so your cable would need to go from line out 1 to input 1. 48V phantom power should be off. You will need low gain for the line level signal. When you switch back to the mic 48V phantom power will need to be on and gain will need to be adjusted to suit the mic level.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
I changed the settings to have the Timing Reference Output, and the Loopback Input to Input 1, which is the channel I plan on using for measurements. Phantom power off. To match the -12dB I had my overall output knob at about 25%, and the input one gain at about 75%. The resulting plot is attached.

I did also get a Low Signal error window, not sure if that is normal during the calibration phase.

Is this looking closer? (no smoothing is applied)
 

Attachments

·
Premium Member
Joined
·
6,711 Posts
In REW you have selected channel 2 as the measurement input, you need to select channel 1 there. The timing reference output and loopback input don't play any role in soundcard calibration.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
JohnM, I really do appreciate your feedback and patience. I think I've got it!

Attached are the calibration curve, and associated settings. It is what I would expect, flat and nearly zero through the audible frequencies. I needed to have my input 1 gain and output levels set to just over the half way point on both to match the -12dB levels.

I also attached my first room measurement (no smoothing). I do still get a "low signal" warning, which I still need to understand and mess with. I set all my levels on my AVR to 85dB at the "0.0 dB" volume setting (Yamaha). When I try to make a room measurement at that level I get clipping errors. So the room measurement attached is at volume of -10dB. If I used the Preferences menu to check levels and set to match the -12dB, I get "too high signal" warnings when making measurements. I assume this can be changed and tailored to the measurement environment. I will probably make a new thread to tackle any questions I can't figure out on that matter after doing some reading.

Again I appreciate all your hard work in the community. Thanks again!
 

Attachments

·
Premium Member
Joined
·
6,711 Posts
The low signal warning is for the reference input, suspect you don't have a loopback connected to it. Can connect a loopback or select 'no timing reference' to stop that coming up. -12 dBFS is good for loopback calibrations, but for room measurements much lower is fine, -30 dBFS is plenty. Otherwise looks good, well done!
 
1 - 13 of 13 Posts
Top