Home Theater Forum and Systems banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello, I am new to REW and the forum.

I installed V.5.17 B11 and was setting it up using my MacBook air speakers and my Berhinger ECM8000 connected to my IrigPro interface. The timing reference sound is heard when I run the measurement.

When I connect to HDMI, the timing reference is not heard but it plays the sweep OK. I was sweeping each speaker and then out of the blue, I heard one timing sound and then it has not come back again.

Any thoughts on the solution?

Mark Harrison
 

·
Premium Member
Joined
·
6,711 Posts
Could you post a screenshot of your REW soundcard preferences? Please also use the Generate debug file button on the soundcard preferences and either attach the file here or send it to me at [email protected]

Which speaker were you measuring when you heard the timing ref?
 

·
Premium Member
Joined
·
6,711 Posts
Thanks. Instead of Aggregate Device try selecting HDMI as the output device and Speaker as the output, then choose the output channel directly from REW. May as well also select Microphone as the input on the iRig Pro rather than leaving it as default device.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Hello John. I just had time last night to try your suggestions.

I made the changes and the timing reference is not heard. I tried it 10 times and no timing signal at all.
 

·
Premium Member
Joined
·
6,711 Posts
Did you remove the aggregate device? The instructions for that method involve muting channels not used for measurement, which could be why the timing reference, which is always on front left or right (depending on which you have selected) is only audible when you measure the same channel as selected for the reference.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I deleted the device and set the drop downs as you you suggested, still no reference sound. It seems to be linked to HDMI connection. When I disconnect the HDMI cable, and route through the mac speakers, I hear the reference sound.
 

·
Premium Member
Joined
·
6,711 Posts
I don't know what else to suggest, sorry. I don't have an OS X HDMI multi-ch setup to test with, but with an 8-ch soundcard all behaves as expected with the timing reference appearing on the selected channel (left or right) whichever channel is selected for measurement. Perhaps worth checking your speaker configuration for HDMI to make sure nothing strange has happened to that as a result of using the aggregate device, a typical setup is shown below.

speakerconfig8ch.png
 

·
Premium Member
Joined
·
6,711 Posts
Everything looks normal, aside from the drop-off at 10 kHz. One possibility is that there is more audio delay when running V5.17 beta 11 because it uses the latest Java runtime for OS X (that is required because the audio routines used by the earlier Java runtime have been deprecated). That might result in the input capture stopping before it has captured the end of the sweep. To check that, make a measurement and go to the scope graph to look at the captured signal, it should drop back to zero after the sweep ends (red trace in the example below), if it is cut off before getting to zero that could be the problem.

scope.jpg

If that is the problem there are two possible solutions. One is to try reducing the output buffer size to 16k (the setting next to the output device selection on the soundcard preferences). The other is to use the Acoustic timing reference option, which is turned on in the Analysis preferences in the Impulse Response Calculation section and then tick the box to "Wait for timing reference" on the measurement dialog.

timingref.jpg
 

·
Registered
Joined
·
6 Posts
Discussion Starter #14
Thanks John.

I am in the process of building some panels for my room. I will reset everything next week and try again and report back.
 

·
Premium Member
Joined
·
6,711 Posts
First you need to do this part (in bold):
The other is to use the Acoustic timing reference option, which is turned on in the Analysis preferences in the Impulse Response Calculation section and then tick the box to "Wait for timing reference" on the measurement dialog.
 
1 - 16 of 16 Posts
Top