Home Theater Forum and Systems banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My Mitsubishi will not turn on after the flashing light goes off. When I first plug it in it will flash rapidly about 10 times and pause and repeat over and over again for 5 to 10 minutes and then stop. No diagnostic codes are displayed when following the procedure for doing so. I have taken the electrical chassis out and removed the covers. The caps on the power board are not swollen. I have not dug deeper as yet. Any suggestions?:dontknow:
 

·
Plain ole user
Joined
·
11,121 Posts
Most likely lots of bad caps. Start looking at the power supply for caps with bulging or high ESR.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thank you for the response. Update: The electrical chassis appears to have been replaced in 2009. I have dug into the chassis and removed the formatter board. The DM is next. So far none of the CPAS look bad on the poser supply, formatter or DM board. It appears that they replaced the 52525 chassis with the 52825 chassis. :dontknow:
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Another new update. As I mentioned in my last post. The chassis was rebuilt in 2009. I thought tha everything was from 52825 but when I removed the DM board I found that the signal board wsfrom a 62525. I also found a couple of CAPS with slight bulges in the top. I am not sure whether or not that would prevent the TV from turning on after the boot light stops blinking. Note that as far as I remember the fan never turned on as well. :dontknow:
 
1 - 4 of 4 Posts
Top