Home Theater Forum and Systems banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm getting this Intermittent hazy appearance that makes the picture look washed out. The colors are still present but it looks really washed out (or appears too bright), and this comes and goes. At times a minor tap on the TV will make this happen or go away.

A service guy came out and said I would need a whole new Signal Board and that something was "loose"??? The problem he said was that they don't make these boards anymore. He gave a quote to fix for $200, then all of a sudden it jumped to $500??? If he could somehow find one out on the market. Not sure how that happened. I'm just not trusting this guy.

The history of the TV is this, two years ago two convergence output chips were replaced (IC), that was $450.00. After reading a few topics here it looks like these chips cost around $15 on ebay?

I did a search and could not find anything that fits the description of the problem I am having now.

Any suggestions as to if the complete signal board needs to be replaced, of if it could be something small that need to be replaced? Are these boards not able to be found now?

I just wonder if it's less expensive to fix myself or better and less hassle to just buy a new Flat screen with a Looooong extended warranty. I love my Mitsubishi though, and it still has a good picture.....when it works right.


Any thoughts would be greatly appreciated
 

·
Plain ole user
Joined
·
11,121 Posts
Sounds like a bad connection somewhere to me. No way to fix that than to try to find what can be moved to affect the problem. Have you checked for a coolant leak onto the boards?
 
1 - 2 of 2 Posts
Top