Home Theater Forum and Systems banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
The mitsubishi ws-55809 can turn on, audio and the menu's work, but none of the video inputs work. I did the code check and it came back as 1-2. There seems to also be a convergence problem? as you can see from the pictures. I read somewhere that if i have a 1-2 error code that it's not convergence, but someone posted that it can still be the convergence. I also read somewhere else that it might be the power regulator? if so where can i find these so i can bypass it and try to take a shot at this. I dont have any of the manuals. By the way, i checked all all the F9A01 all the way to F9A06 fuses and they were all working properly.Any type of help would be GREATLY appreciated. Thanks so much.

Please see pictures attached.
 

Attachments

·
Plain ole user
Joined
·
11,121 Posts
The error codes only identify the reason for a protect shutdown. If the set is running it should give you a 1-2 code, even if there is some other problem. It looks like you have no convergence correction at all. Can you adjust it in any way? Have you checked carefully for coolant on the boards? Checked the voltages at the convergence ICs to verify the + and - supplies?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Icaillo, Thank you very much for such a quick reply, I greatly appreciate the help. I can not adjust the convergence manually through the menu. And i just checked for any leakage and i found this ( see pictures attached) it is towards the front under the lenses, it looks like something blew or burnt. Could this be leakage? Can i resolder this? Apart from the convergence problem, i read somewhere that the video input problem might be due to a faulty voltage regulator, is there any way you can point out to me on my picture where the voltage regulator for the video could be so i can bypass the voltage regulator with a 9 volt battery. Lastly, i found where the Ic's are, how do i go about testing them? do i have to pull the whole board out? Thank you.

Read more: WS-55809 Problem w/Pictures Attached - Home Theater Forum - Home Theater Systems - HomeTheaterShack.com http://www.hometheatershack.com/for...roblem-w-pictures-attached.html#ixzz0gg6NsSL8
 

Attachments

·
Plain ole user
Joined
·
11,121 Posts
You are basically asking for a course in how to fix your set. I will give some general guidance, but specific step-by-step help is beyond the scope of the forum.

There are a couple of threads on coolant leaks. Read those carefully. The board will need to be cleaned, the corroded areas repaired, including likely some of the feed-thoughs that go from one side of the board to the other. You will need so be able to check the continuity of traces and you should have a service manual and schematic to veirfy connections.

Regulators are usually attached to heat sinks. I suggest you NOT substitue voltages. The problems in th regulator circuits are usually capacitors, and these should be checked with an ESR meter. Other problems are bad solder connections. Look for ring cracks with a magnifier.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thank you for your help. I will test and resolder the area that looks bad. In your opinion do you think I should change the convergence ICs while Im in there. Thanks.
 

·
Plain ole user
Joined
·
11,121 Posts
I suggest doing one thing at a time.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Thanks for all the help, i will update you on my findings. Can you recommend a certain trusted legit website to order the convergence chips from?
 

·
Plain ole user
Joined
·
11,121 Posts
Read the stickies very carefully. There are suggested vendors in the parts thread for the convergence repair sticky. My preferred vendors are Acme and B&D.
 
1 - 8 of 8 Posts
Top