Home Theater Forum and Systems banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have pulled the dm power board the capacitors do not look bulged. Another thread suggested that i replace them anyway. also someone wrote that if space allowed to increase the voltage of the capacitors? so should i stick with the exact specification, or the higher voltage?

Thanks
 

·
Registered
Joined
·
94 Posts
If your originals are 1000uf at 10 or 16v, try going with either a 680uf at 25v or 1000uf at 25v.

Yes, you'll have to change them first before you can begin to troubleshoot for either a DM problem or an E2P problem.

Good luck,
Jim
 

·
Plain ole user
Joined
·
11,121 Posts
Just make sure that they are low impedance caps, long life caps. Just going up on the voltage, with all else the same, you might get caps with higher impedance and make it more likely to have problems.
 

·
Plain ole user
Joined
·
11,121 Posts
As low as you can find in the proper value and size. You may not get good specs and may only find general descriptors. Use reputable manufacturers like panasonic and sanyo for caps.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
replaced caps. It turned on for test now i just dont remember where the flat ground strap goes when installing rear cover. Does it go on bottom srew of dm chassis, or the bracket next to it?? Thanks
 

·
Registered
Joined
·
94 Posts
From the DM to the metal bracket. I don't usually remove it from both sides, so I can't say with absolute certainty.
Can you post a picture of the area you are talking about, I know from looking at it.

Jim
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
ok so now the unit powers up. after approx 2 minutes it shuts down and front panel light blinks for approx 30 seconds. front panel control will only turn it on, and remote will only turn it on. i put 640uf 25 v caps in so next step is???
 

·
Registered
Joined
·
94 Posts
640uf???? What does the front blink? Green constant or Red?

1st step is to check all plugs first, make sure there isn't one left disconnected. Also with Mitsubishi, all the plugs and sockets are labeled. Recheck an make sure one isn't in the wrong spot.

Jim
 

·
Plain ole user
Joined
·
11,121 Posts
ok so now the unit powers up. after approx 2 minutes it shuts down and front panel light blinks for approx 30 seconds. front panel control will only turn it on, and remote will only turn it on. i put 640uf 25 v caps in so next step is???
Pull the diagnostic code. Hold the menu and input buttons down simultaneously for more than 5 seconds and note the 2 digit flashing code on the LED.
 

·
Registered
Joined
·
94 Posts
Yeah, what he said!!

LOL,,,, I had one of those end up with a constant blink after replacing caps, turned out to be a failing button jamming the bus. When I held the buttons for the error code, it released the volume down button that failed. Sometimes I get in a hurry, and can't write what I think...

Jim
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
ok i tried to do the diagnostic mode. None of the front panel buttons work after i turn it on. direct tv remote will turn it on or off. it turns off after about 90 seconds and blinks just like after pressing front panel reset. i will get back into rear panel and check connections next.
 

·
Plain ole user
Joined
·
11,121 Posts
This may be one of the sets that has the front panel lockout option. IIRC pressing the menu button for more than 10 seconds clears it, but check your manual. Also common on these are bad front panel control switches that will tie up the micro and cause odd behavior. You can disconnect the control panel and operate with the remote to test this. Sometimes pressing the switches repeatedly clears the problem, at least for a while.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #17
Thanks to all who gave advice it is working great now!! connector VA was pulled off while i slid the chassis back in to cabinet i saw it by removing front access panel. :bigsmile::wave:
 

·
Plain ole user
Joined
·
11,121 Posts
Naw, never happened to me...:rolleyes:
 

·
Registered
Joined
·
94 Posts
I worked till 3:00am one morning trying to figure out why a computer monitor that had a bad power supply didn't have video after I fixed the power supply. Gave up then.

Next morning, told my most junior tech to go check out the monitor. Result, the video cable came off the computer.......And I was the service manager..
 
1 - 20 of 22 Posts
Top