Home Theater Forum and Systems banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Good Morning,

I was given this Mitsubishi WS 55511 set. It looks like the previous owner changed the IC chip STK393-110 and the 2 fuses. He did a POOR solder job. Lucky that I have a friend who cleaned it up. OK,

The set powers up, sound, picture. But I can not adjust the convergence with the remote. The picture is hour glassed and the color overlays are off, due to the lack of adjustment.

What am I looking at replacing? Did he "fry" the IC chip with his "solder job"?

Any input on the matter is GREATLY appreciated.

Thanks,

Bob
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
When I get home tonite, I will check to see if the fuses are shot. If the fuses were blown, from what I have been reading the set will run, but the convergence will not work? Am I correct in this assumption? If the fuses check out OK, is there a manual adjustment for the convergence? Thanks, Bob
 

·
Plain ole user
Joined
·
11,121 Posts
I don't think it will run if the fuses are blown but am not sure on that model. One of the first things that one checks as a tech is what supplies are coming up and which are not. If one is not, then we check the fuses.

In the case of this chassis, the circuit may be a little more complex than typical and require additional troubleshooting skills.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Just got home and checked both fuses,,, Both are OK. Going to let it run for awhile and see if the IC has any warmth to it. Will check back after dinner.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Also, still no adjustment available by using the remote. Can get into the program, but nothing happens when I try to move either the cross hairs or the grid adjustment. Thanks.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Just wondered if the resistors could be at fault? Was reading another post about the lack of movement of the crosshairs. Something else to look at tomorrow evening.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Well, going to order the IC tomorrow. From what I have been reading on here, that should solve my adjustment or the lack of adjustment problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Well after waiting several weeks for my friend to get the IC chip STK393-110 and resistors installed on the board, I got it in and attempted to adjusted the convergence. Still not adjustment possible. Either with the remote or the controls on the front of the set. Everything else works on the set. Is there a manual method of adjusting the convergence? What else could I be looking for that would cause the lack of adjustment. Fuses are fine. Thanks. Bob
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Had a friend go thru the board with the meter, following the wiring schematic. He added some jumpers to the ic, as he said some of the foil was not making contact, due to a poor (overheated) solder job on the first IC replacement. It looks like the crosshairs are closer, but still not able to adjust using the remote. Any ideas as to where we should look now? I am also considering looking for a total replacement board, if that is possible? Thanks for your assistance.[MOUSE][/MOUSE]
 

·
Plain ole user
Joined
·
11,121 Posts
Read the convergence repair sticky posts very carefully. Verify the supply voltages at the ICs and that all of the resistors and connections to the ICs are intact. Replacement boards would need to come from Mitsubish unless you find a used or rebuilt one. There is usually little reason to replace the board, however.

You cold have a problem with the convergence generator, but testing this would require a scope and some troubleshooting experience.
 

·
Plain ole user
Joined
·
11,121 Posts
What board? Part number? Why a board?
 
1 - 13 of 13 Posts
Top