Home Theater Forum and Systems banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello everyone, I have a Mitsu WT-43211 that fails to turn on. Has the typical fault that I have read on the posts. When the power is selected on, the green led flashes and a click is heard and it fails to turn on. Holding the menu and input shows the 2 pause 2 fault code. I have removed the back cover and getting ready to start T/S. Im looking at any that might be an easy fix, loose connector, loose solder joints etc... My first question, when i pull the light box, is it ok to lay the box on its side? While I inspect the solder joints. Im afraid it may leak coolant as I have heard that it will happen.
 

·
Plain ole user
Joined
·
11,121 Posts
These models do not have coolant leak problems. You likely have a convergence failure, or a problem in the convergence power supply.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
thanks for the input, thats where I will start my TS. I was able to find the service manual for the WT43211 I will study the WD.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 · (Edited)
Well I have taken the Mitsu apart, have the board tray out and looking it over, so far no blown fuses that I can see, checking all the solder joints at the IC, all looking to be secured. I think I will pull the IC first and start with that. OHm checked all the fuses: F9B01, F9A04, F9A03, F9A02, F9D00, AND F9A05, they all check good with the fluke meter.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
, I have the wrong service manual for this model. I have to find the service manual for WT42311, I cant find the problem so I will needed, if anyone has a link to a service manual in pdf, please drop me a message.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
I think its time to call a tech to look it over, I have checked all that I can check, I'm thinking its a power supply problem, or a problem in the Con/gen. I have the IC's out and it still does not turn on, I'm trying to check the for + - at the ic's but I'm not able since the tv shut its self down to quick.
 
1 - 7 of 7 Posts
Top