Home Theater Forum and Systems banner

1 - 3 of 3 Posts

·
Senior Shackster , Platinum Supporter
Joined
·
828 Posts
Discussion Starter #1
I had some problems with my Sanyo Plv-Z3, after 10 or 15 minutes of watching a movie the screen turned green ( only happened with the HDMI input) so I bypassed the receiver and hooked my other DVD player and it was still there so then I replaced the HDMI cable and it worked fine for couple of days and it did it again so I sent the unit to Sanyo, they paid for shipping both ways, this is if your projector still under warranty(3 years), send the unit on Monday and got it back on Friday, that was quick:T, they upgraded the flash memory, cleaned the LCD panels, and the best part they replaced the filters for free:yay:, so far its good but my main thing is that it was pretty quick for them to fix it, the tech guys are really nice, most of the time when I send something to be fixed it takes for ever to get it back:waiting:, I was very impressed with Sanyo, I will definitely buy another Sanyo projector!!:5stars::eek:utstanding:
 

·
Banned
Joined
·
22,577 Posts
Wow... that was super quick turnaround with excellent service. You should post that in the Manufacturers Service and Support forum as well. Sanyo has not had a good rep on service in the past.
 

·
Elite Shackster , HTS Moderator Emeritus
Joined
·
2,216 Posts
That makes me happy I got a Sanyo as well (Z4). I had heard the negative stuff too. So far no problems though.
 
1 - 3 of 3 Posts
Top